Forums

Registration

Click here to register. Registration is required if you want to post to the forums.

If you register, we can also contact you with news on new module versions, and upgrades to new modules as we make them available. 

Use of your registration information is subject to our privacy policy.

Inventua Forums

Subject: SQL Execute Command - PayPal
Prev Next
You are not authorized to post a reply.

Author Messages
alliance alliance
Posts:6

02 Apr 2012 12:03 AM  

 Hi,

I want to know if the following sql statement is correct because it doesn't work:

UPDATE UserBalance SET Balance = Balance - '$quantity'
WHERE UserID = '$dnnuserid'

Thanks.

 

Anthony Glenwright
Posts:10620

02 Apr 2012 12:40 AM  
If your SQL has generated an error then it will be in the DNN event log (Admin->Event viewer), so the first thing to do is to check there.

alliance alliance
Posts:6

02 Apr 2012 6:27 PM  

That was the first thing that I check but there is no error in the event viewer. Running the simple instruction Update UserBalance Set Balance = 0.0 (without tokens) does not reflect changes in the reference table.

Do I need to set something (other than the payment notification) to run the sql command?

Thanks.

Anthony Glenwright
Posts:10620

02 Apr 2012 7:25 PM  
You will need to set the "log IPN data to the event log" setting and then check the event log to make sure that you are receiving the IPN.
alliance alliance
Posts:6

02 Apr 2012 8:02 PM  
I already set the "log IPN data to the event log" to on and the sql command function isn't work. I do not know I'm doing wrong or how to make it work. A simple instruction to update does not work. The event viewer doesn't show nothing wrong.

Any ideas?
Anthony Glenwright
Posts:10620

02 Apr 2012 8:28 PM  
It sounds like your web server is not receiving the IPN

1. Make sure that you are not testing from a private IP address (like localhost)
2. Make sure that the page, and the PayPal module are visible to "all users"
alliance alliance
Posts:6

02 Apr 2012 9:56 PM  
I set the page to be viewed by all users and now works perfectly!!. That is the only way that the module works? The page where I have the module I need only to be viewed by registered users.

The like the module, it would be good if I could do that.

Thanks!!
alliance alliance
Posts:6

02 Apr 2012 10:24 PM  
Ok, I found the way to do what I need. I put the page for all users and the module visible to registered members only. Works 100%. I love the module and the support is fantastic!!. I will buy the module.

Thank you very much.
Anthony Glenwright
Posts:10620

02 Apr 2012 10:53 PM  
You should have to make the module visible to "all users". Otherwise the module won't be rendered when the IPN POST comes to your site.
You are not authorized to post a reply.



ActiveForums 3.7